首页 文章 精选 留言 我的

精选列表

搜索[内存超频],共10011篇文章
优秀的个人博客,低调大师

Rustls —— 内存安全的 TLS 实现

Rustls 是一个用 Rust 编写的现代 TLS 库;它使用ring进行加密,使用webpki进行证书验证。Rustls 成熟且使用广泛。虽然大多数 API surface是稳定的,但开发团队预计接下来的几个版本将根据需要进行进一步更改,以适应新功能或性能改进。 Rustls 旨在提供良好的加密安全级别,无需配置即可实现该安全性,并且不提供不安全的功能或过时的加密技术。 当前功能 TLS1.2 和 TLS1.3。 客户端的 ECDSA、Ed25519 或 RSA 服务器身份验证。 通过服务器进行 ECDSA、Ed25519 或 RSA 服务器身份验证。 使用 ECDHE 的前向保密;使用 curve25519、nistp256 或 nistp384 曲线。 AES128-GCM 和 AES256-GCM 批量加密,具有安全随机数。 ChaCha20-Poly1305 批量加密 (RFC7905)。 ALPN 支持。 SNI 支持。 可调片段大小,使 TLS 消息匹配底层传输的大小。 可选地使用矢量 IO 来最小化系统调用。 TLS1.2 会话恢复。 通过tickets恢复 TLS1.2(RFC5077)。 TLS1.3 通过票据或会话存储恢复。 客户端的 TLS1.3 0-RTT 数据。 服务器的 TLS1.3 0-RTT 数据。 由客户端进行客户端身份验证。 服务器进行客户端身份验证。 扩展的主密钥支持 (RFC7627)。 Exporters (RFC5705) OCSP 由服务器装订。 通过服务器进行 SCT 装订。 客户的 SCT 验证。 未来可能的功能 支持PSK。 客户端的 OCSP 验证。 Certificate pinning

资源下载

更多资源
Mario

Mario

马里奥是站在游戏界顶峰的超人气多面角色。马里奥靠吃蘑菇成长,特征是大鼻子、头戴帽子、身穿背带裤,还留着胡子。与他的双胞胎兄弟路易基一起,长年担任任天堂的招牌角色。

腾讯云软件源

腾讯云软件源

为解决软件依赖安装时官方源访问速度慢的问题,腾讯云为一些软件搭建了缓存服务。您可以通过使用腾讯云软件源站来提升依赖包的安装速度。为了方便用户自由搭建服务架构,目前腾讯云软件源站支持公网访问和内网访问。

Sublime Text

Sublime Text

Sublime Text具有漂亮的用户界面和强大的功能,例如代码缩略图,Python的插件,代码段等。还可自定义键绑定,菜单和工具栏。Sublime Text 的主要功能包括:拼写检查,书签,完整的 Python API , Goto 功能,即时项目切换,多选择,多窗口等等。Sublime Text 是一个跨平台的编辑器,同时支持Windows、Linux、Mac OS X等操作系统。

WebStorm

WebStorm

WebStorm 是jetbrains公司旗下一款JavaScript 开发工具。目前已经被广大中国JS开发者誉为“Web前端开发神器”、“最强大的HTML5编辑器”、“最智能的JavaScript IDE”等。与IntelliJ IDEA同源,继承了IntelliJ IDEA强大的JS部分的功能。

用户登录
用户注册