首页 文章 精选 留言 我的

精选列表

搜索[版本发布],共10000篇文章
优秀的个人博客,低调大师

sagacity-sqltoy 睿智 ORM 框架 5.0.7、 4.18.31 版本发布

开源地址: github:https://github.com/sagframe/sagacity-sqltoy gitee:https://gitee.com/sagacity/sagacity-sqltoy idea 插件(可直接在idea中检索安装):https://github.com/threefish/sqltoy-idea-plugins 更新内容 1.修复oracle数据库oracle.sql.TIMESTAMP 转LocalDateTime的支持 sqltoy特点介绍: sqltoy最佳sql编写模式,便于开发和后期维护 sqltoy的缓存翻译,大幅减少表关联简化sql,让你的查询性能成几何级提升 极致的分页,同样帮助你实现查询的性能大幅提升 快速分页:@fast() 实现先取单页数据然后再关联查询,极大提升速度 分页优化器:page-optimize 让分页查询由两次变成1.3~1.5次(用缓存实现相同查询条件的总记录数量在一定周期内无需重复查询 sqltoy的分页取总记录的过程不是简单的select count(1) from (原始sql);而是智能判断是否变成:select count(1) from 'from后语句', 并自动剔除最外层的order by sqltoy支持并行查询:parallel="true",同时查询总记录数和单页数据,大幅提升性能 便利的跨数据库统计计算:数据旋转 便利的跨数据库统计计算:无限极分组统计(含汇总求平均) 便利的跨数据库统计计算:同比环比

优秀的个人博客,低调大师

go-carbon 1.3.8 版本发布,新增 ToXXXStringWithTimezone 系列方法

carbon 是一个轻量级、语义化、对开发者友好的Golang时间处理库,支持链式调用、农历和gorm、xorm等主流orm。 如果您觉得不错,请给个 star 吧 github:github.com/golang-module/carbon gitee:gitee.com/go-package/carbon 更新日志 修复 Carbon 转换成 time.Time 时未带时区的 bug 新增 ToDateTimeStringWithTimezone () 方法输出指定时区的日期时间字符串 新增 ToDateStringWithTimezone () 方法输出指定时区的日期字符串 新增 ToTimeStringWithTimezone () 方法输出指定时区的时间字符串 新增 ToAnsicStringWithTimezone () 方法输出指定时区的 Ansic 格式字符串 新增 ToAtomStringWithTimezone () 方法输出指定时区的 Atom 格式字符串 新增 ToUnixDateStringWithTimezone () 方法输出指定时区的 UnixDate 格式字符串 新增 ToRubyDateStringWithTimezone () 方法输出指定时区的 RubyDate 格式字符串 新增 ToKitchenStringWithTimezone () 方法输出指定时区的 Kitchen 格式字符串 新增 ToCookieStringWithTimezone () 方法输出指定时区的 Cookie 格式字符串 新增 ToDayDateTimeStringWithTimezone () 方法输出指定时区的 DayDateTime 格式字符串 新增 ToRssStringWithTimezone () 方法输出指定时区的 RSS 格式字符串 新增 ToW3cStringWithTimezone () 方法输出指定时区的 W3C 格式字符串 新增 ToRfc822StringWithTimezone () 方法输出指定时区的 RFC822 格式字符串 新增 ToRfc822zStringWithTimezone () 方法输出指定时区的 RFC822Z 格式字符串 新增 ToRfc850StringWithTimezone () 方法输出指定时区的 RFC850 格式字符串 新增 ToRfc1036StringWithTimezone () 方法输出指定时区的 RFC1036 格式字符串 新增 ToRfc1123StringWithTimezone () 方法输出指定时区的 RFC1123 格式字符串 新增 ToRfc2822StringWithTimezone () 方法输出指定时区的 RFC2822 格式字符串 新增 ToRfc3339StringWithTimezone () 方法输出指定时区的 RFC3339 格式字符串 新增 ToRfc7231StringWithTimezone () 方法输出指定时区的 RFC7231 格式字符串

优秀的个人博客,低调大师

OOX 0.0.2 版本发布, 极简 NodeJS 接口开发框架

OOX 是什么 一个天生支持微服务/单体应用无缝切换的服务框架, 超级适合初创公司, 节省初期上线成本, 又能满足爆发式发展需求 一个天生支持分布式链路跟踪的分布式系统, 超级适合多人团队并行开发, 函数级日志联调优化, 节省bug调试与优化成本 一个天生支持 边缘计算, ABI友好 的嵌入式系统, 模块化的设计和类P2P服务发现方式, 配合 WebSocket 长连接, 无论什么应用场景, 都能做到得心应手 更新了什么 本次更新优化了SocketIO连接拦截方式, 具体为使用抛异常替换传统的方法调用 const { Service } = require ( 'oox' ) module.exports = class extends Service { static SocketIO = class extends Service.SocketIO { onSocketConnection ( socket ) { const { headers } = socket.handshake const isValid = headers [ 'x-caller' ] === 'client' // 当前优化后的使用方式 if ( !isValid ) throw new Error ( '连接失败' ) // 优化前的使用方式 if ( !isValid ) return socket.send ( '连接失败' ).disconnect ( true ) super.onSocketConnection ( socket ) } } } 有什么特性 HTTP 及 socket.io 服务双加持 0 配置启动服务 0 配置服务节点无限动态扩展 0侵入式编码, 极致简洁体验 0 侵入实现分布式链路跟踪 最符合直觉的路由模式 最符合直觉的服务调用方式 任何地方都能设置拦截器, 极致权限控制 自动服务发现 (P2P) 自动负载均衡 (可自定义算法) `分布式 / 独立应用`无缝切换! "Jawa"级性能, 吊打一切! 其它牛逼特性, 正在探索中

优秀的个人博客,低调大师

go-carbon 1.3.0 版本发布,新增 XXXNoOverflow() 系列方法

carbon 是一个轻量级、语义化、对开发者友好的Golang时间处理库,支持链式调用、农历和gorm、xorm等主流orm 如果您觉得不错,请给个 star 吧 github:github.com/golang-module/carbon gitee:gitee.com/go-package/carbon 更新日志 新增AddXXXNoOverflow()和SubXXXNoOverflow()系列方法处理月份溢出问题 新增ParseByLayout()方法,将布局时间字符串解析成 Carbon 实例 CreateFromGoTime()更名为Time2Carbon(),作用是将 time.Time 转换成 Carbon ToGoTime()更名为Carbon2Time(),作用是将 Carbon 转换成 time.Time 优化Format()方法,增加对\\符号支持,表示原样输出不解析 优化Format()方法,增加对S符号的支持,表示月份中的第几天,英文缩写后缀,如st、nd、rd、th,一般和j配合使用 优化解析异常时的错误文案 优化精简两个时间大小判断逻辑代码 // 一年后 carbon.Parse("2020-02-29 13:14:15").AddYear().ToDateTimeString() // 2021-03-01 13:14:15 // 一年后(月份不溢出) carbon.Parse("2020-02-29 13:14:15").AddYearNoOverflow().ToDateTimeString() // 2021-02-28 13:14:15 // 原样输出不解析 carbon.Parse("2020-08-05 13:14:15").Format("l jS \\o\\f F Y h:i:s A") // Wednesday 5th of August 2020 01:14:15 PM // 将布局时间字符串解析成 Carbon 实例 carbon.ParseByLayout("It is 2020-08-05 13:14:15", "It is 2006-01-02 15:04:05").ToDateTimeString // 2020-08-05 13:14:15 // 将 time.Time 转换成 Carbon carbon.Time2Carbon(time.Now()) // 将 Carbon 转换成 time.Time carbon.Now().Carbon2Time() 或 carbon.Now().Time

资源下载

更多资源
Mario

Mario

马里奥是站在游戏界顶峰的超人气多面角色。马里奥靠吃蘑菇成长,特征是大鼻子、头戴帽子、身穿背带裤,还留着胡子。与他的双胞胎兄弟路易基一起,长年担任任天堂的招牌角色。

Nacos

Nacos

Nacos /nɑ:kəʊs/ 是 Dynamic Naming and Configuration Service 的首字母简称,一个易于构建 AI Agent 应用的动态服务发现、配置管理和AI智能体管理平台。Nacos 致力于帮助您发现、配置和管理微服务及AI智能体应用。Nacos 提供了一组简单易用的特性集,帮助您快速实现动态服务发现、服务配置、服务元数据、流量管理。Nacos 帮助您更敏捷和容易地构建、交付和管理微服务平台。

Rocky Linux

Rocky Linux

Rocky Linux(中文名:洛基)是由Gregory Kurtzer于2020年12月发起的企业级Linux发行版,作为CentOS稳定版停止维护后与RHEL(Red Hat Enterprise Linux)完全兼容的开源替代方案,由社区拥有并管理,支持x86_64、aarch64等架构。其通过重新编译RHEL源代码提供长期稳定性,采用模块化包装和SELinux安全架构,默认包含GNOME桌面环境及XFS文件系统,支持十年生命周期更新。

Sublime Text

Sublime Text

Sublime Text具有漂亮的用户界面和强大的功能,例如代码缩略图,Python的插件,代码段等。还可自定义键绑定,菜单和工具栏。Sublime Text 的主要功能包括:拼写检查,书签,完整的 Python API , Goto 功能,即时项目切换,多选择,多窗口等等。Sublime Text 是一个跨平台的编辑器,同时支持Windows、Linux、Mac OS X等操作系统。

用户登录
用户注册