低调大师

您现在的位置是: 首页 > ubuntu下安装rabbitMQ

文章详情

ubuntu下安装rabbitMQ

2015-2-5 11:59 26已围观 收藏 加入我们

一.环境准备

    rabbitMQ需要erlang语言的支持,因此需要先安装erlang语言

二.下载

    http://www.erlang.org/download/opt_src_17.3_tar.gz    并解压

三.安装

    ./configure --prefix=/home/liyixiang/erlang

注:

    可能会报错 configure: error: No curses library functions found configure: error: /bin/sh '/home/liyixiang/erlang/configure' failed for erts

原因是缺少ncurses包    

解决:在ubuntu系统下

apt-cache search ncurses

apt-get install libncurses5-dev

继续安装erlang

    命令:make  make install

四.测试erlang

    进入/home/liyixiang/erlang,启动erl测试erlang是否安装成功。

五.配置erlang环境变量   

  1. 修改/etc/profile文件,增加下面的环境变量:(vim profile    i插入  编辑完毕ESC退出   wq!强制修改

  2. #set erlang environment

  3. export PATH=$PATH:/usr/erlang/bin:$PATH

  4. source profile使得文件生效

六.rabbitMq安装配置

  下载 http://www.rabbitmq.com/releases/rabbitmq-server/v3.3.5/rabbitmq-server-generic-unix-3.3.5.tar.gz

解压放入usr下

  1. 修改/etc/profile,添加环境变量

  2. #set rabbitmq environment

  3. export PATH=$PATH:/usr/rabbitmq_server-3.3.5/sbin

  4. source profile使得文件生效

注:

    可能会遇到 ./rabbitmq-server: line 86: erl: command not found 

        修改rabbitmq_server-3.3.5/sbin/rabbitmq-server-3.3.5文件 将 export PATH=$PATH:/usr/erlang/bin配置上即可

然后启动./rabbitmq-server.start !!


七.rabbitmq web管理页面插件安装

  1. #cd /usr/rabbitmq_server-3.3.5/sbin   

  2. #mkdir /etc/rabbitmq/    (如果不创建会报Error: {cannot_write_enabled_plugins_file,            "/usr/rabbitmq_server-3.3.5/sbin/../etc/rabbit)

  3. #rabbitmq-plugins enable rabbitmq_management

 


文章转载至:https://my.oschina.net/liyixiangBlog/blog/375619
收藏 (0)

文章评论

共有0条评论来说两句吧...